понедельник, 18 декабря 2017 г.

ОГЭ-10: 4B5C6B

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.


Алгоритмический язык
алг
нач
 целтаб Dat[1:11]
 цел  k, m
 Dat[1] := 20; Dat[2] := 25
 Dat[3] := 19; Dat[4] := 25
 Dat[5] := 26; Dat[6] := 22
 Dat[7] := 24; Dat[8] := 28
 Dat[9] := 26; Dat[10] := 21
 Dat[11] := 27
 m := 0
 нц для k от 1 до 11
   если k > 9  то
    m := m + Dat[k]
   все
 кц
 вывод m
кон

Бейсик
Паскаль
DIM Dat(11) AS INTEGER
DIM k,m AS INTEGER
Dat(1) = 20: Dat(2) = 25
Dat(3) = 19: Dat(4) = 25
Dat(5) = 26: Dat(6) = 22
Dat(7) = 24: Dat(8) = 28
Dat(9) = 26: Dat(10) = 21
Dat(11) = 27
m = 0
FOR k = 1 TO 11
IF k > 9 THEN
m = m + Dat(k)
END IF
NEXT k
PRINT m
Var k, m: integer;
Dat: array[1..11] of integer;
Begin
 Dat[1] := 20;  Dat[2] := 25;
 Dat[3] := 19;  Dat[4] := 25;
 Dat[5] := 26;  Dat[6] := 22;
 Dat[7] := 24;  Dat[8] := 28;
 Dat[9] := 26;  Dat[10] := 21;
 Dat[11] := 27;
 m := 0;
 for k := 1  to 11 do
   if  k > 9 then
     begin
       m := m + Dat[k]
     end;
 writeln(m)
End.
Ответ:
48

Комментариев нет:

Отправить комментарий